Email delivery delay
Incident Report for Chameleon
Resolved
Outbound received a large volume of API traffic which caused the slowdown but they are all caught up now.
Posted over 2 years ago. Aug 26, 2016 - 11:52 PDT
Monitoring
Our email processor (Outbound.io) is experiencing some slowdown in processing resulting in delays for sign up and log In emails in the range of 10 mins to 1 hour. They are actively investigating this.

We suggest you use Google or Intercom authentication to sign up or log in to your account where possible to avoid this issue.
Posted over 2 years ago. Aug 26, 2016 - 10:07 PDT