Website load times
Incident Report for Chameleon
Resolved
Website load times should be back to normal for the affected regions.
Posted 8 days ago. Apr 11, 2019 - 10:48 PDT
Investigating
We're seeing increased load times for customers viewing the website from Europe and Asia and are currently investigating.
Posted 8 days ago. Apr 11, 2019 - 10:00 PDT